Lag...again

Report a bug or find troubleshooting tips for known issues.
Forum rules
Before starting a thread, please check to make sure that others have not already reported the same issue. When reporting a bug, please try to provide a screenshot and to describe the proper instance in order for us to replicate the issue. After an issue has been confirmed and/or fixed on our end, the topic for it will be locked to prevent further reports. For all payment related issues, please open a ticket at http://cloudcade.helpshift.com to receive immediate support.
internetz
"Great" Mastery Member
Posts: 219
Joined: Mon May 16, 2016 1:22 pm

Re: Lag...again

Postby internetz » Sat Sep 16, 2017 1:01 pm

Molly wrote:
cc_Darkis wrote:Not seeing much on our end but the team is still checking things out regardless.

It's funny to read this. While almost everyone alternately suffers from significant lags.
Every weekend.

Strongly reminiscent of the lack of computing resources in the cloud.

I click "Sell" and wait couple of seconds. Click&Wait. Click&Wait. Wow, one item sold instantly! And Click&Wait again...


this weekend, the lag is not something cloudcade can do anything about. ping shopheroes-cdn.cloudcade.com and look for lag spikes, or do a traceroute, and you'll probably notice that in the section of the trace where it's hopping through google routers, there are routers that are offline or unresponsive.

User avatar
Shiroe
"Legendary" Mastery Member
Posts: 2530
Joined: Sun Aug 23, 2015 11:05 am
Location: the Netherlands
Contact:

Re: Lag...again

Postby Shiroe » Sat Sep 16, 2017 6:51 pm

internetz wrote:this weekend, the lag is not something cloudcade can do anything about. ping shopheroes-cdn.cloudcade.com and look for lag spikes, or do a traceroute, and you'll probably notice that in the section of the trace where it's hopping through google routers, there are routers that are offline or unresponsive.

Googled a bit and unless the blotches of orange/red there are normal, there might be some highways of the internet blocked and having their traffic redirected onto the rest of them causing traffic jams:
http://downdetector.com/status/level3/map/
as of 2016-09-11: Player level: 44, City: Eolythes, Blueprints: 517, Mastered: 419, Crafted: 78.61K
(except for tier 1 and some tier 2 artifacts mostly running my shop/gearing self sufficient)

User avatar
cc_Darkis
Cloudcade Staff
Posts: 508
Joined: Mon Mar 20, 2017 1:50 pm

Re: Lag...again

Postby cc_Darkis » Mon Sep 18, 2017 12:36 pm

Yup it was something out of our hands guys. Team tried to do what they can but some folks had it pretty bad game wise.
"Cauldron is like a box of chocolates. You never know what you're gonna get."~river#44249 :D
"Gems of Shop Heroes are like diamonds of real life."~Prometheus :o

Arckont
Posts: 2
Joined: Fri Apr 14, 2017 12:13 am

Re: Lag...again

Postby Arckont » Tue Sep 19, 2017 1:16 am

I can confirm that I usually got lag on desktop game but not in Android , in the same time period. if I switch between Android and desktop one would lag but not the other.

internetz
"Great" Mastery Member
Posts: 219
Joined: Mon May 16, 2016 1:22 pm

Re: Lag...again

Postby internetz » Thu Sep 21, 2017 9:56 pm

It's really bad right now... not sure if it's another google/routing issue, or something on your end, cloudcade, but i'm not seeing the dropped packets in my traceroute anymore(avg 29.2ms ping), so if you could make sure it's not the server, that'd be great :)

bowloftoast
"Great" Mastery Member
Posts: 161
Joined: Fri Jul 31, 2015 9:48 am

Re: Lag...again

Postby bowloftoast » Fri Sep 22, 2017 8:17 am

internetz wrote:It's really bad right now... not sure if it's another google/routing issue, or something on your end, cloudcade, but i'm not seeing the dropped packets in my traceroute anymore(avg 29.2ms ping), so if you could make sure it's not the server, that'd be great :)

Image

User avatar
Shiroe
"Legendary" Mastery Member
Posts: 2530
Joined: Sun Aug 23, 2015 11:05 am
Location: the Netherlands
Contact:

Re: Lag...again

Postby Shiroe » Fri Sep 22, 2017 8:51 am

Personally I haven't experienced lag yet this raid (Steam and android, the Netherlands), but I saw someone mention having bad lag earlier in world chat. (I think he/she was playing on android in New York state(?) (sorry, not too familiar with north american geography))
as of 2016-09-11: Player level: 44, City: Eolythes, Blueprints: 517, Mastered: 419, Crafted: 78.61K
(except for tier 1 and some tier 2 artifacts mostly running my shop/gearing self sufficient)

Molly
"Good" Mastery Member
Posts: 56
Joined: Wed Jan 18, 2017 7:41 pm

Re: Lag...again

Postby Molly » Tue Sep 26, 2017 10:42 am

internetz wrote:this weekend, the lag is not something cloudcade can do anything about. ping shopheroes-cdn.cloudcade.com and look for lag spikes


Stable 22ms without spikes. Google services isn't down. No L3 outage in my region.

Image

Image

Image


But three times restarting the game, I had a big pause here:

Image

After that I was not able to take the result from the cauldron.

After 15 minutes (while I was doing screenshots and wrote here) I managed to load the game without pause and even walk the market without long delays! After another 15 minutes, the lag can return in full ...

internetz
"Great" Mastery Member
Posts: 219
Joined: Mon May 16, 2016 1:22 pm

Re: Lag...again

Postby internetz » Tue Sep 26, 2017 8:53 pm

i posted that 10 days ago (september 16).... maybe pay attention to dates?

anyway, the spot it's stalling at for you is during the login process, where it is attempting to contact
http://status-sh.cloudcade.com:8888
Of course, that server isn't set up to respond to pings, so without a debugging proxy installed, you wont be able to figure out if that's the issue or not. you could install charles trial version if you were interested in seeing if that's where your problem lies, assuming you're using the pc version and not the phone version of shopheroes.

User avatar
Shiroe
"Legendary" Mastery Member
Posts: 2530
Joined: Sun Aug 23, 2015 11:05 am
Location: the Netherlands
Contact:

Re: Lag...again

Postby Shiroe » Wed Sep 27, 2017 12:15 am

internetz wrote:i posted that 10 days ago (september 16).... maybe pay attention to dates?

anyway, the spot it's stalling at for you is during the login process, where it is attempting to contact
http://status-sh.cloudcade.com:8888
Of course, that server isn't set up to respond to pings, so without a debugging proxy installed, you wont be able to figure out if that's the issue or not. you could install charles trial version if you were interested in seeing if that's where your problem lies, assuming you're using the pc version and not the phone version of shopheroes.

Well, since you're interested in packets, not their contents, for a phone/tablet on a home wlan, you should still be able to run something like tcpdump or wireshark on a laptop/desktop on the (w)lan.
Hmm, I had no lag at all during the raid, but had a bunch of lag this monday, so I guess it's a possibility that one of the server instances is hickuping (giving lag) while the others are fine and you only get lag if RNGesus assigns you to that troublemaker. (had something like that in another game now and then: game yapping about certificates error - the bad server instance)
as of 2016-09-11: Player level: 44, City: Eolythes, Blueprints: 517, Mastered: 419, Crafted: 78.61K
(except for tier 1 and some tier 2 artifacts mostly running my shop/gearing self sufficient)


Return to “Bugs & Issues”



Who is online

Users browsing this forum: Bing [Bot] and 3 guests

©2015 Cloudcade, Inc. All Rights Reserved.