unable to run unity web player on firefox

Ask for help from veteran players and find answers not listed in the FAQ.
Forum rules
You can find answers to our FAQs within our in-game support system, also available at http://cloudcade.helpshift.com
yongzel
Posts: 1
Joined: Fri Jul 21, 2017 10:14 pm

unable to run unity web player on firefox

Postby yongzel » Fri Jul 21, 2017 10:17 pm

the reason that I need to switch from chrome to firefox and install unity is obvious: memory shortage and webGL crash
so far I've done these:
1. downloaded unity web player on this site.
2. install unity properly without any problem on my mac.
3. downloaded current version firefox.
4. mac version : 10.11.6
5. no unity plugin on firefox plugin page

can anyone please give me a hand here
many thanks

paljar
Posts: 29
Joined: Wed May 17, 2017 2:01 pm

Re: unable to run unity web player on firefox

Postby paljar » Fri Jul 21, 2017 11:09 pm

This guide, is given by many players, including me, on kongregate chat to players with the same question, it is as far as I know the best solution to play on kongregate and is still working with the latest patch of firefox:
http://winaero.com/blog/firefox-52-npap ... -disabled/

User avatar
Shiroe
"Legendary" Mastery Member
Posts: 2530
Joined: Sun Aug 23, 2015 11:05 am
Location: the Netherlands
Contact:

Re: unable to run unity web player on firefox

Postby Shiroe » Sat Jul 22, 2017 2:03 am

paljar wrote:This guide, is given by many players, including me, on kongregate chat to players with the same question, it is as far as I know the best solution to play on kongregate and is still working with the latest patch of firefox:
http://winaero.com/blog/firefox-52-npap ... -disabled/

Well, that page lists "Note: With Firefox 53, the ability to restore NPAPI plugin support will be removed completely." (Firefox current is 54), so I guess Firefox 52 ESR is the way to go if you still need Webplayer.
https://www.mozilla.org/en-US/firefox/o ... tions/faq/
https://www.mozilla.org/en-US/firefox/o ... tions/all/
as of 2016-09-11: Player level: 44, City: Eolythes, Blueprints: 517, Mastered: 419, Crafted: 78.61K
(except for tier 1 and some tier 2 artifacts mostly running my shop/gearing self sufficient)

paljar
Posts: 29
Joined: Wed May 17, 2017 2:01 pm

Re: unable to run unity web player on firefox

Postby paljar » Sat Jul 22, 2017 10:59 am

Shiroe wrote:
paljar wrote:This guide, is given by many players, including me, on kongregate chat to players with the same question, it is as far as I know the best solution to play on kongregate and is still working with the latest patch of firefox:
http://winaero.com/blog/firefox-52-npap ... -disabled/

Well, that page lists "Note: With Firefox 53, the ability to restore NPAPI plugin support will be removed completely." (Firefox current is 54), so I guess Firefox 52 ESR is the way to go if you still need Webplayer.
https://www.mozilla.org/en-US/firefox/o ... tions/faq/
https://www.mozilla.org/en-US/firefox/o ... tions/all/


Tha tline of the guide is untrue, it still works fine.

User avatar
Hiws
"Flawless" Mastery Member
Posts: 307
Joined: Mon Jan 18, 2016 8:48 am
Location: Denmark

Re: unable to run unity web player on firefox

Postby Hiws » Sun Jul 23, 2017 9:02 am

yongzel wrote:the reason that I need to switch from chrome to firefox and install unity is obvious: memory shortage and webGL crash
so far I've done these:
1. downloaded unity web player on this site.
2. install unity properly without any problem on my mac.
3. downloaded current version firefox.
4. mac version : 10.11.6
5. no unity plugin on firefox plugin page

can anyone please give me a hand here
many thanks


If you're running MAC. Just use Safari. It can run Unity without any "hacks".
But if you really want to use Firefox, follow the guide paljar linked.

paljar
Posts: 29
Joined: Wed May 17, 2017 2:01 pm

Re: unable to run unity web player on firefox

Postby paljar » Fri Sep 22, 2017 11:06 am

There have been some changes on this topic:

1. It seems that with some update it is no longer possible to use unity at the latest firefox patch using the guide above, and it is also very hard to downgrade back to ESR, because firefox saves some crucial settings on your pc.

2. Some users switched to the palemoon browser, at which you can run unity perfectly

3. yesterday i discovered that unity is enabled again at internet explorer (not at edge), I cannot find any official info about this, but tested it at 2 pc's and shop heroes worked at unity at both pc's using internet explorer.

4. It is also possible to run at chrome not using webgl, by using gameload application.


Return to “Help & Questions”



Who is online

Users browsing this forum: No registered users and 4 guests

©2015 Cloudcade, Inc. All Rights Reserved.